Tag Archives: repository

php5 update on CentOS

If you have CentOS v5.2 then you have PHP v5.1.6. Any PHP5 systems need PHP5 > v5.2.
The php-sqlite2 library has a problem to update so that you must delete it:
yum erase php-sqlite2
Now, you have got any solutions:

    Update PHP5 to last stable version and create /etc/yum.repos.d/CentOS-Testing.repo with this content:

    [c5-testing]
    name=CentOS-5 Testing
    baseurl=http://dev.centos.org/centos/$releasever/testing/$basearch/
    enabled=1
    gpgcheck=1
    gpgkey=http://dev.centos.org/centos/RPM-GPG-KEY-CentOS-testing
    includepkgs=php*

    Update PHP5 to last beta version and create /etc/yum.repos.d/utterramblings.repo with this content:

    [utterramblings]
    name=Jason's Utter Ramblings Repo
    baseurl=http://www.jasonlitka.com/media/EL$releasever/$basearch/
    enabled=1
    gpgcheck=1
    gpgkey=http://www.jasonlitka.com/media/RPM-GPG-KEY-jlitka

Now, you could update system:
yum update

Reference: wiki.centos.org and jasonlitka.com