Tag Archives: package management

yum segmentation fault in centos

After an upgrading with yum program, yum will end with segmentation fault.

Last link about libz is the cause:
-rwxr-xr-x 1 root root  75028  9 gen  2007 libz.so.1.2.3
-rwxr-xr-x 1 root bin   96572  8 nov  2010 libz.so.1.2.5
-rw-r--r-- 1 root bin  101462  8 nov  2010 libz.a
lrwxrwxrwx 1 root root     13  8 apr  2011 libz.so -> libz.so.1.2.3
lrwxrwxrwx 1 root root     13  8 apr  2011 libz.so.1 -> libz.so.1.2.5

libz.so.1 need a different link:
lrwxrwxrwx 1 root root     13  8 apr  2011 libz.so.1 -> libz.so.1.2.3

Reference: yum fails with segfault after source zlib upgrade

apt-cache

NAME
apt-cache – APT package handling utility — cache manipulator
SYNOPSYS
apt-cache [-hvsn] [-o=config string] [-c=file] {[add file...] | [gencaches] | [showpkg pkg...] | [showsrc pkg...] | [stats] | [dump] | [dumpavail] | [unmet] | [search regex] | [show pkg...] | [depends pkg...] | [rdepends pkg...] | [pkgnames prefix] | [dotty pkg...] | [xvcg pkg...] | [policy pkgs...] | [madison pkgs...]}

EXAMPLE
apt-cache search emacs

apt-get

NAME
apt-get – APT package handling utility — command-line interface
SYNOPSYS
apt-get [-sqdyfmubV] [-o= config_string ] [-c= config_file ] [-t= { target_release_name | target_release_number_expression }] {update | upgrade | dselect-upgrade | dist-upgrade | install pkg [ { =pkg_version_number | /target_release_name } ] ... | remove pkg... | purge pkg... | source pkg [ =pkg_version_number ] ... | build-dep pkg... | check | clean | autoclean | autoremove | {-v | --version} | {-h | --help}}

EXAMPLE
apt-get install emacs